Having problems with your Canon PowerShot A85 Digital Camera ?

LCD screen shows menu, programes etc but does not show image in auto shoot mode.

Answers :

This sounds like it might be a defective CCD imager. If so, Canon should fix this for you for free worldwide, and may also include free shipping both ways (free shipping varies with countries). This is regardless of your camera's warranty status. Please check this link for more info.\015\012
\015\012Applicable cameras include:\015\012A60, A70, A75, A80, A85, A95, A300, A310, S1 IS, S60, S230, S400, S410, S500, SD100, SD110, IXUS V2/V3/300/400/430/500/II/IIs, IXY Digital 200a/300a/320/400/450/500/30/30a \015\012
Repair Help & Product Troubleshooting for Canon PowerShot A85 Digital Camera

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

No image on LCD screen, only irregular lines of varied coloring. When picture is snapped, it is of these lines--no image. Help. Details: I turned the camera to shooting mode but it does not display the image of what I want to shoot, but just a series of horizontal lines. If I take the shot, it shows the lines which were displayed on the LCD screen. If switched to playback mode, previously shot images show up fine. I checked the batteries; they were fine. I replaced them anyway, to no avai

I have the same problem and after doing research, I found this website. ... Canon PowerShot S1 IS Digital Camera

LCD screen shows menu, programes etc but does not show image in auto shoot mode.

This sounds like it might be a defective CCD imager. If so, Canon should fix this for you for free worldwide, and may also include free shipping both ways (free shipping varies with countries). This is regardless of your camera's warranty status. ... Canon PowerShot A85 Digital Camera

Powershot s410 My s410 is "old" :( but I love it and has been working amazingly over 10,000 photos in the 4 years I've had it. All of a sudden this week-end when I am in auto or manual mode the screen is black - I can't see what I am shooting. What is odd is that if I am in the panoramic mode or video mode the screen works. Even odder is that if I actually take a picture blindly (since the screen is black) it shows up on the display! Help... :) Thanks

Since it is taking a picture, and showing it up afterwards on the display, it definitely sounds like you activated the DISP or DISPLAY button. Seeing that you've used this camera for years, you should know that this manually turns the screen on and ... Canon PowerShot S410 / IXUS 430 Digital Camera

No image The LCD screen flickers, nothing is visible, no shooting of image. However, on shutter click in Auto mode the flash operates but does not record any image. In view mode, the already recorded images are displayed.

No image in shooting mode on Canon S500. Flash operates and shutter clicks. Whats wrong? ... Canon PowerShot S500 IXUS 500 Digital Camera

Lcd does not show image when camera is in shooting mode, but does show image when displaying the storage card and menu screens

HI,\015\012\015\012THis is the problem with the CCD device,\015\012\015\012Your CCD is worn and you need to replace your CCD..\015\012\015\012Please rate this solution\015\012RNJ VINODKUMAR ... Canon PowerShot S2 IS Digital Camera

I dropped my Powershot A 530, and since then i am not able to see any image on the screen, and when i shoot it regardless i get blank images on the memory card. The previous images that i had taken are still on the card and show up when i switch to memory/picture mode. Any ideas what might be the problem?

Either a "cracked" logic-board, or loose wires from the video-screen, so that nothing (except "darkness") is being sent from the photo-sensors to the logic-board.\012\012Copy all the pictures from the card onto your PC, and then buy a new ... Canon PowerShot A530 Digital Camera

My Sony A700 works ok in the P,A,S and M modes. However when set in Auto mode the lcd shows Portrait. When in Portrait it shows Portrait. When in Landscape the lcd shows Portrait. When in Macro it shows Manual.When in Sports action it show Manual. In Sunset it shows Nightime. It also shows Nightime in both the Nightime and Memory Recall modes. The +/- button calls up the ISO screen instead of the ev screen. What's the solution?

Has it been serviced before? I remember one A200 with a very similar problem. There was a flex cable broken inside - the owner had given it to another technician before me and he managed to brake it. I think it could be a bad connection or some liqui ... Sony Alpha DSLR-A700

In camera (shooting) mode, image on showing on LCD screen

This sounds like it might be a defective CCD imager. If so, Canon should fix this for you for free worldwide, and may also include free shipping both ways (free shipping varies with countries). This is regardless of your camera's warranty status. ... Canon PowerShot A70 Digital Camera

Similar problems as other readers. camera turns on but no real time image on LCD screen. LCD contiues to show settings i.e. full auto mode etc. But I can view pictures already taken. Thanks

The XTi and prior EOS models have not capability to see the live image to be shoot on the screen. Only the image after taken can see on the screen. Other images also using the view mode.If you can't review the images, eve if the display i ... Canon EOS 400D / Rebel XTi Digital Camera

Hi, I have a Canon IXUS 95IS camera.. For some reason, when I attempt to take a photo, the LCD screen isn't displaying what is actually in view? In movie mode it comes up on the screen but when i flick it to Auto or camera mode, the screen goes black and only shows the little icons... Weirdly enough, it still takes the picture but the really annoying thing is it doesn't show up on the screen what you're taking a photo of so it makes it really hard for the person taking the actually photo... can

Ah yes! you have pressed the display button. Turn the camera on and you see the icons in the display, look for the Disp button and press it, the display will cycle through its modes icons, black, image and icons. ... Digital Cameras

Blank LCD screen on shooting mode, but does show settings. Will not take pictures. Replaying mode works, shows pictures taken before screen went blank. New batteries. What is going on??? Is it fixable? I bought the Canon PowerShot A570 IS. I don't know if it is me or the camera but my LCD screen doesn't stay on. I can take a phote, the photo will then display on the LCD for 2 seconds BUT then the LCD goes blank, all i can see are the menu options. If I take a pic while LCD is blank my pic's

The Display button manually turns the LCD display on or off to save batteries. If you accidentally had turned the LCD off, It should only take one press of the button to turn it back on and leave it that way. As such, it's not you but the camera. ... Canon PowerShot A570 IS Digital Camera

Hi, I have a Canon T2i Rebel. When i put the camera in "M" (totally manual), the image doesnt appear in the LCD screen. Everything else works fine in the monitor, but it is as if the lens where covered with the cap. But it´s not, and acutally all the other modes work fine. Only in the manual mode the image doesnt show, and the pictures also appear completely black. The menu shows sometimes something as if the exposure were less than -2, but even though i change the values for everything hig

That's great news, so let's write it up as a solution so that other people who search on here find the right information!So it appears that the Canon T2i when in manual mode (M) remembers whatever settings you play with, and that these se ... Canon EOS 550D Rebel T2i Digital Camera

My PowerShot SD400 Digital Elph is not showing images on my screen when i turn it on to shoot ... but images show up when i go to the review shot screen...help!

Push the display button. ... Canon PowerShot SD400 / IXUS 50 Digital Camera

Help No image in the viewfinder or on the lcd screen when in shooting mode. Have amber light rather than green. In playback mode images appear on lcd screen. Was working fine the last time I used it and have changed the batteries to newly charged. Have also reset to default settings.

This sounds like it might be a defective CCD imager. If so, Canon should fix this for you for free, including free shipping both ways. This is regardless of your camera's warranty status. Please check the following two links for more info:\015\ ... Canon PowerShot S1 IS Digital Camera

When I turn the camera on, the image that I am shooting does not show on the LCD monitor. When I switch the camera mode to view images I have taken previously, they show up but the new images are not showing (they are completely black) Can you help?

There are many point you may want to look at.\015\012\015\012first, if the LCD does not display the picture you just capture, there is a possibility that the digital module of the device is broken and that it does not show or save the pic ... Digital Cameras

Blank screen My Canon Powershot SD600, when in picture taking mode, does not show any images on the screen -- it is dark. However, in video mode and play mode, it is just fine so I know the screen still works. And it can take pictures, I just can't see anything!

Sounds like you accidentally pressed the DISP (Display) button on the back of your camera. This manually turns the screen on and off in picture taking mode to save battery power. You could then use the optical viewfinder in its place. To turn it b ... Canon PowerShot SD600 Digital Camera

My Panasonic DMC-TZ3 in any shooting mode produces the following both on the screen and in a captured image: a blurry, snowy, magenta-tinted (visual noise?) presentation. At one point, it produced several normal images, then returned to the problem. The playback mode produces normal images from sored normal images. I have never dropped the camera or exposed it to high heat or cold. I have 3 batteries and none produce any variance in the bad image. I've tied all settings and reset. Up until the

The problem you have mentioned is definitely a case of image sensor malfunction since the distortions are appearing in the pictures too. Getting the imagesensor replaced is the only way to fix this problem. ... Panasonic Lumix DMC-TZ3 Digital Camera

Canon SD 550-- sensor problem? Bought 3/2006 and have had no problems. Suddenly, LED screen went black--shows nothing and cannot take a picture altho will flash and record black picture. Shooting options do appear on screen when in picture-taking mode. Can see pictures that were taken previously, however, while showing them on TV screen, camera shuts off. Is this an expensive repair. Thanks.

The shutter of the camera is not opening that is why every picture taken is recorded black. It is a mechanical problem and probably has nothing to do with the sensor. Not very expensive ... Canon Digital Cameras

The flash no longer works. In "auto" and in either the "auto flash" mode or "forced flash" mode no flash occurs. It is not in "suppressed flash" in the "portrait" screen position mode. The batteries are good. The shutter button is pressed after the charging is completed. The camera is not in "continuous shooting."

Hi there, \012Well first of all try to reset your camera, remove the battery from your camera for 4 hours and then insert them again, it helps you to do a hard reset in your camera. if further you have the same problem then there mus ... Fuji FinePix 3800 Digital Camera

I have a Canon XM3 camcorder. It has given me many years of good service. Recently it has developed a fault. When I switch it onto Camera mode, and then flip the switch to Standby, the small screen flickers blue for a short time, but it does not show the image from the lens. If I switch off, and sitch to Playback, the small screen works OK and all the Playback works fine. Sometimes when I switch to Camera, and Standby, the small screen flickers blue, and then an image from the lens appears, but

Its the problem of CCD assembly\015\012CCD (image sensor) failures, particularly in conditions of high heat and humidity, led to cameras capturing images with either no picture at all, or with extreme distortion and se ... Digital Cameras

My Nikon D90 has started to shoot images with what appears to be hair in lens, Switched lense to Macro and hair is still there It is always in varying shapes, so to speak But is ruining my images It is most prevalent with Blue sky background/ Really then you can see it Also trid taking it out of manual Mode to Auto still was not shooting Clear Images??? Thank you

If you switch lenses and the hair is still appearing on your pictures, it is quite possible you have an actual hair or thread or something located in the camera body in the way of the sensor. Remove your lens and visually examine the inside of the b ... Nikon D90 Digital Camera with 18-105mm lens

In camera mode, screen shows a blend of image and digital spectrum analyzer bars blurring the image

The ony way is to get the CCD replaced with a new one. Contact NIKON for free replacement as this comes under manufacturing defect. ... Nikon Coolpix 5700 Digital Camera

I'm suddenly having an issue w/ my new D3000. When shooting, the image doesn't show on the screen. It does appear after shooting for review, but when taking the photo, the screen is black/grey. I haven't had this happen before and don't know if it's a body or lens issue. Help!!

If you've really been seeing the image before taking the shot, then there was something seriously wrong with your camera which now appears to have fixed itself. The D3000 doesn't have the LiveView feature. The screen is for the menu and reviewing ima ... Nikon Digital Cameras

When I try to take a picture, the LCD displays a lot of colorfull squiggly lines instead of the scene that I want to capture. When I turn it ON, the Zoom lens extends normally, then the colored lines appear with the following settings on the screen. Auto, 1M 178, ISO 400, ! plus a hand icon, AUTO, 4, F2.8. No matter which mode I choose, the same thing happens. Looking through the EVF shows the same thing. Note; I can view several good pictures that I took before the problem showed up. If I

This would be caused by a defective CCD sensor inside rad this advisory from canon below:\015\012\015\012http://www.dpre ... Fuji FinePix S5000 Digital Camera

When camera is in shooting mode the screen is blank. switch to replay mode and screen will show stored photos OK.

Is it still taking pictures even though nothing is showing up on the screen. If so, then there is just a loose connection between the lens and the screen so let me know what the exact situation is based off of my first sentence and I would be happy t ... Digital Cameras
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.lionebra.com || Terms of Use || Contact || Privacy Policy
Load time: 3.3309 seconds