Having problems with your Nikon D40x Digital Camera ?

LCD show purple or violet cast on white areas when using auto mode


\015 D40x / 18-55 DX Nikkor lense... preview on the LCD of indoor pictures of white objects appear purple or violet... any ideas? is it a malfunction of the LCD\015

Answers :

Have you tried viewing the photos on a computer or printing them? There should also be parts of the menu/setting displays that would be white. The text on the image info should be in white.
If you are getting white, it would suggest your whitebalance isn't set correctly. If everything has a purple tint to it, check your LCD display settings, otherwise it may be the screen is failing.
Repair Help & Product Troubleshooting for Nikon D40x Digital Camera

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

LCD show purple or violet cast on white areas when using auto mode


Have you tried viewing the photos on a computer or printing them? There should also be parts of the menu/setting displays that would be white. The text on the image info should be in white.If you are getting white, it would suggest your whiteba ... Nikon D40x Digital Camera

Horizontal purple bar on LCD in camera mode. Have changed batteries. Used different batteries. Different memory cards. LCD works normal except in camera mode. When shutter is pressed purple bar shows on LCD


When you change the mode to camera, the sensor of the camera begins to work. Unfortunately your sensor is dead from now on. This kind of sensor, I mean point and shoot camera sensors always do that. There is nothing to do. The sensor life and the qua ... Canon PowerShot A95 Digital Camera

I was taking pictures outside using a tripod mounting and had my Fujifilm FinePix S5000 on in photography mode - Auto mode. Upon placing the tripod for a new photo, I observed that the LCD monitor had turned white with intermittent horizontal flashing black lines. The view through the viewfinder is also white but without the black lines. When a photograph is taken the image is white. I should point out that in Playback mode I can view previously taken photographs perfectly on both the moni


Hi,It seems ccd imager chip problem, ccd imager chip is electronics device that converts an image into electronics signal. It is located at end of lens assembly in camera.CCD imager chip will be replaced to get correct view in camera mode ... Fuji Digital Cameras

The LCD Monitor of my Canon PowerShot A95 shows purple, white, and black horizontal lines instead of a clear image of what is in the Viewfinder. Pictures taken while showing up this way on the LCD Monitor turn out with the same fuzzy stripes. Light lines show up in the well-lit areas of the scene and dark lines show up where the scene is dark. The problem was intermittent for months but now cannot be corrected by powering off. Thanks, Steve


See this FixYa link. ... Canon PowerShot A95 Digital Camera

After dropping the camera, all pictures show purple glow where white is supposed to be. Sometimes it returns to normal when using the zoom. I tried resetting to factory settings, but to no avail, the very bright purple color stays. (in lcd and in end result on sd card.)


Http://www.usa.canon.com/cusa/support/consumer/digital_cameras/other_powershot/powershot_sx2 ... Canon PowerShot SX 200 IS Digital Camera

My Sony A700 works ok in the P,A,S and M modes. However when set in Auto mode the lcd shows Portrait. When in Portrait it shows Portrait. When in Landscape the lcd shows Portrait. When in Macro it shows Manual.When in Sports action it show Manual. In Sunset it shows Nightime. It also shows Nightime in both the Nightime and Memory Recall modes. The +/- button calls up the ISO screen instead of the ev screen. What's the solution?


Has it been serviced before? I remember one A200 with a very similar problem. There was a flex cable broken inside - the owner had given it to another technician before me and he managed to brake it. I think it could be a bad connection or some liqui ... Sony Alpha DSLR-A700

Bought this product on 28/03-08 at bangalore.all snaps taken out-doors becomes too whitish and not able to see anything, the lcd screen on review shows no snap..but white over exposed result even at auto-mode. cannot take any snaps outdoors in ordinary day light.indoors with flash result is excellent.pl help. b.a.v.baliga


Make sure your ISO setting is set to Auto. Even in auto mode its possible to set your ISO manually. If the ISO is set to auto and the pictures are still to bright, your sensor may be bad. Also make sure your exposure compensation is set to 0. ... Kodak EasyShare C613 Digital Camera

My kodak EasyShare V1253 has a purple cast to the picture that shows in the screen area before i am going to take the picture and sometimes if i wiggle the camera the purple will go out of it and sometime not. It also shows purple in the photo, what canI do to fix this?


... Kodak EASYSHARE V1253 Digital Camera

I have 2 Sony cameras with problems..one is a DSC-T1..there is no picture when in the camera mode..will display pictures made earlier..lcd is blank in camera mode. The other camera is DSC-F717..Camera has hardly been used..in camera mode the lcd only shows a smeared image..the image is not recgonizable. Strange conicidence, but both failed nerly at the same time.


Hi kd4kdp,\015\012Both of your camera have bad CCD Imagers and must be replaced. Good news for you is that Sony will replaced these parts free of cost. Check more details on following Sony web link. Have nice day.\015\0121= ... Digital Cameras

My Canon EOS Digital Rebel LCD Screen just shows an all-white display instead of picture preview. The same when I turn it on. This happened while I was using it. I set it down to use another camera and the display went white when I took another picture.


... Canon Digital Rebel / EOS-300D Digital Camera with EF-S 18-55mm Lens

When I try to take a picture, the LCD displays a lot of colorfull squiggly lines instead of the scene that I want to capture. When I turn it ON, the Zoom lens extends normally, then the colored lines appear with the following settings on the screen. Auto, 1M 178, ISO 400, ! plus a hand icon, AUTO, 4, F2.8. No matter which mode I choose, the same thing happens. Looking through the EVF shows the same thing. Note; I can view several good pictures that I took before the problem showed up. If I


This would be caused by a defective CCD sensor inside rad this advisory from canon below:\015\012\015\012http://www.dpre ... Fuji FinePix S5000 Digital Camera

Hi, I have a Canon IXUS 95IS camera.. For some reason, when I attempt to take a photo, the LCD screen isn't displaying what is actually in view? In movie mode it comes up on the screen but when i flick it to Auto or camera mode, the screen goes black and only shows the little icons... Weirdly enough, it still takes the picture but the really annoying thing is it doesn't show up on the screen what you're taking a photo of so it makes it really hard for the person taking the actually photo... can


Ah yes! you have pressed the display button. Turn the camera on and you see the icons in the display, look for the Disp button and press it, the display will cycle through its modes icons, black, image and icons. ... Digital Cameras

Nikon CoolPix S500 shows colored lines on lcd and in photos where the lights are bright. I have restored settings tried using it with no flash, soft flash, and auto flash and the problem continues. Noticed the lines on the lcd over a year ago and it has progressed to brightly lit photos also now. In some photos lighter colors also show up with the lines. ie. My daughters blonde hair in the light looks almost transparent with all the lines running through it. Is this a lens problem? Is there


... Nikon COOLPIX S500 Digital Camera

I HAVE A GR2 DIGITAL CAMERA. I usually shoot in manual mode and and set white balance manually using a digital callabration target. Yesterday afternoon, after shooting most of theday without problems, my images started appearing completely washed out with an orange cast. This cast also was all over my calibration target image. The image was unclear with stripes running horizontally across my display. This problem is present in all modes. Itried everything I could think of to resolve the matter


I doubt that formatting the card will do anything but, if you choose to do that, download any pics first since formatting will completely erase the card. Have you tried going back to "Auto WB" to see if your camera works properly that way? How about ... Ricoh GR Digital Camera

White balance I have an ongoing problem with all my images having a stronge red / yellow color cast to them. It does not matter if I'm in the daylight or shooting under flouresent lights. When I use my flash the area directly in front of the flash is usually ok, but where the flash falls off, the immediate area has that color cast to it. Example: If I take a picture of the front fender, of a vehicle from six feet away, the fender is usually ok but the chrome wheel, tire and pavement have the red


Use real color mode, saturation set to normal. ... Sony Cyber-Shot DSC-F828 Digital Camera

I was taking test photos around the house with my new camera and the flash won't fire properly (the flash pops up out of the camera but it makes little sparking sounds and flickering on and off). I've tried various modes including auto night etc but it won't stop flickering (just sparking sounds and a flickering flash like a light bulbs does just before it blows).also I have tried taking images using the basic auto mode in a low lit area and the flash pops up but does not fire.


I think top cover is faulty it s giveing error 05. if poop up and giving err99\015\012then flash pcb faulty other wise need to replace top cover. ... Canon EOS Rebel XSi Digital Camera

I can not get the auto flash to work The screen shows on the left: iso auto, a box, M1 on the right the flash symbol A, auto, steady hand symbol, 1375 I try to take a picture and the camera won't take unless I turn off the flash. I have tried to change many settings in the function area, but I can not figure out what I accidentally changed in the first place. please help me to get my camera to work in the auto mode again


I have this same exact problem. When you say "repair it," how? ... Canon PowerShot A720 IS Digital Camera

Canon power shot S230 elph. I have two of them and they both use to get purple, magenta lines showing up in LCD display. I just happen to power them on again and one seems to be working but the other will view prior pictures fine in the LCD but when trying to take a new picture it very dark in LCD and picture is dark almost black when viewing. Flash is going off when taking a picture.rn Thank you, Cindy


... Canon PowerShot S230 / IXUS 179 Digital Camera

Pictures striped Wenn i was taking pictures today, suddenly (no change in the mode or menu) the taken pictures showed horizontal white stripes, very bad. The pictures are no use anymore! I really don't know how this could happen and how to repair this defect. I could show an image for example but I don't know how on this site?


1. Do the pictures look the same on your computer after downloading them? If so, try another memory card. If the same, your camera is defective, bring it to service.\015\0122. If OK with another memory, try to reformat the defective memory, if that d ... Ricoh Caplio R5 Digital Camera

My pictures have a yellow cast to them and they are not very sharp. When I take pictures outside, my photos are invariably washed out. I find myself manually adjusting light balance before I print (either darkening if I take picture outside or lightening if I take the picture inside). I almost always use Auto mode. I have found nothing that corrects the nasty yellow cast.


Have you changed the white balance setting? ... Digital Cameras

When control dial is set to Tv the lcd says it is in P mode, When set to Av it says M. When set to portrait, it says full auto, the control dial will only show P, M, A-DEP,full auto and sports. I have updated the firmware, but still the dial does not give all the functions. Any ideas??


Sorry we are not able to help you with your problem. ... Canon EOS Rebel XSi Digital Camera

My shooting mode dial is not working properly. when i switch the mode dial to auto it show as manual on my LCD. camera type is powershot A580. thanks


... Canon PowerShot S500 IXUS 500 Digital Camera

My nikon D40 is taking dark pictures on P Mode even when the flash is in use, and the white balance is set to auto, but the ISO setting is set to 200 and won't let me go to Auto. The Exposure Compensation is at 0.0 I am running out of options. How can this be fixed?


Hi,Check if your shutter speed is not to fast. Try using a longer exposure time.Cheers ... Nikon D40X Digital SLR Camera Digital Camera with 18-55mm Lens

Have a canon DSLR EOS1000D with Sigma 70-300mm lens. When using on auto modes it will not take images and shows message camera not communicating with lens clean lens contacts. Have tried this with no success. On none outomatic modes works fine.


Have you cleaned the contacts on both the camera body and lens with a cotton swab lightly dampened with rubbing alcohol? ... Canon Rebel XS / Eos 1000D Digital Camera with EF-S 18-55mm f& EF 75-300mm f Lens

The flash is either far too bright or not bright enough even when using the auto setting. The flash either doesn't flash at all on "soft flash" and then blinds people when the flash is turned on so it produces very dark faces or bright white images. I've tried using different scene modes but this does not seem to work.


... Casio Exilim EX-S880 Digital Camera
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.lionebra.com || Terms of Use || Contact || Privacy Policy
Load time: 0.2470 seconds